My BluSCSI Nightmare


We have a Macintosh Classic in the fleet that has a bad floppy controller on it. The computer is fine otherwise, but neither the internal floppy drive nor external header work anymore. I've tried a few fixes over the years, but nothing has worked- and sourcing a new chip for this one is more expensive than it's really worth. The Mac Classic has a neat trick where when you hold Control-Option-X-O it'll load a version of Mac System off of a rom chip, so it's gone to shows all the same. The downside being, it can't run any external software.

My plan to fix that was to get a BluSCSI that can be slotted inside and replace the hard drive, giving it a bunch of games to play at our shows. I bought one of these forever ago, and set off to get this working about a month ago.

As of this writing, I'm just about to the point of throwing the thing away. Every part of setting up and using this device is like pulling teeth, and the documentation for this thing is a mess as there are so many versions and variations on it.

The simple gist is that one has to format an SD card, then load Macintosh system software onto the card so that it thinks it is a hard drive. Sounds simple, but trying to follow the various tutorials out there, I've found that the tools one needs to do that is crazy. To configure a BluSCSI you need, per the YouTubers and blogs I read:

A Windows 10 computer with an SD card adapter
A modern Macintosh computer with an SD card adapter
A classic mac for the BluSCSI to go into
A working classic Mac to configure the BluSCSI for the other classic Mac
A Macintosh emulator of dubious quality

-and maybe-
An Amiga 500 or better with hard drive (to serve as the working Mac)
A Floppy Emu device
A SCSI2SD device (to configure the BluSCSI)
A Power Macintosh G4 (running OS-X-Tiger) with an SD card adapter
A Linux server (to serve as the emulator)

After ten different attempts, I have yet to get the BluSCSI to work with any Mac in the fleet- including known good machines like my Performa 410. I don't know what I'm doing wrong.

While I'm complaining, I'll also say that the Basilisk II emulator never started for me no matter how much I tried to load it. SheepShaver refused to even start on Windows, so when I finally broke down and dug out the 2014 iMac to run the emulator there, it complained of "misconfigured memory" and though it would start, it would never copy or move anything the way that I wanted it to. When I finally got a browser-based Mac emulator (MinivMac) to do what I wanted it to, the BluSCSI doesn't run as intended. I've followed everything step by step as close as I can, I don't know what to do with this one.

As of now, with the show coming up and other machines needing attention, I'm planning to just cut this machine from the lineup entirely unless I have some epiphany and figure out whatever it is I'm missing.

In closing, I like the BluSCSI as a product. As for actually using it, I've found it to be very confusing and difficult to use. I have experience with these sort of aftermarket peripherals and have all the tools listed above, but still wasn't able to get it working. Just sucks.

If anyone here has any ideas or is interested in taking a crack at it, give a shout.